$re = '/(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)/m';
$str = '12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;