// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)").unwrap();
let string = "12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}