re = /(.*)((?:\/\*|\/\/|--).*)/
str = '/*blah blah*/ab 123
abcksklsdnvnkd // dnvsv EOD
data --ccomments EOD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end