package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w-]+`)
var str = `[ 1234, jack, 1987-09-02]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}