$re = '/^[0-9]+([,][0-9]{1,2})?$/';
$str = '2,03
3
43,5
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);