const regex = new RegExp('^[0-9]+([,][0-9]{1,2})?$', '')
const str = `2,03
3
43,5
23,000.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}