import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\ban?|\\b)test(ing|s|\\d|\\b)";
final String string = "this is a test\n"
+ "just a test\n"
+ "atest\n"
+ "testament\n"
+ "antest\n"
+ "latest\n"
+ "Test3\n"
+ "da bestest script ev4r\n"
+ "test#3\n\n"
+ "New Userscript test make sure that you have this one installed too. https://greasyfork.org/en/scripts/381982-new-userscript\n"
+ "rere test test\n"
+ "test script test script 1\n"
+ "Delicious Favicon Tweak - Test - Not Working Tweak of \"Favilink\" for Delcious : Adds a favicon to all links\n"
+ "XHR without barriers -- test Scripting is fun\n"
+ "TEST all tests for my extensions\n"
+ "Simple test script Give a table to help manage cities\n"
+ "Test Script Cross Domain POST All tests are outputed to developer javascript console (try F12 hotkey)\n"
+ "~ test ~ Enhances your experience on HackForums! c:\n"
+ "Naruto-Boards Test Skin Changes NB layout\n"
+ "Wanikani Review Count Analysis [TEST] Reports review counts.\n"
+ "TM test show SI and REREC in TM Player page\n"
+ "test test doing\n"
+ "Politics and War Helper - Test Server Adds useful functions to the Game Politics and War - Test Server\n"
+ "test 444 Agar ztx\"\n"
+ "Test Alert Test\n"
+ "test test desc\n"
+ "WME TTS test Play TTS\n"
+ "Fur Affinity Test UI Homepage Original concept art by Mailylion. Replaces the landing page with a new theme.\n"
+ "AH Clan Extension test #1 D - Double Split -|- S - Triple Split -|- A - 16 Split -|- Q - Feed\n"
+ "Test Tampermonkey by Marvin try to take over the world!\n"
+ "Test Bot cok New Free Agar.io Bot Service!\n"
+ "JV Notes de test Affiche les notes des jeux sur la page de listing\n"
+ "test for dual extestion try to take over the world!\n"
+ "test なんでも良いからテストでインストールしたい人へ\n"
+ "PTE Cheat Test Server auto PTE-Cheat\n"
+ "Tải nhạc video và hình ảnh từ youtube test Download nhạc chất lượng cao tại mp3.zing.vn (chỉ áp dụng cho bài hát kô bao gồm album) và nút tải nhạc ở youtube\n"
+ "LAUFLICHTS UPDaTES TEST wer faul ist und klicks ersparen will nimmt dieses script\n"
+ "TurkerHub Speech Recognition test. Testing out Chrome's current variant of the Speech Recognition API on our favorite mark, TurkerHub.\n"
+ "Test Testing\n"
+ "Timer Discrepancy Test Timer descrepancy test to demonstrate background tab timer throttling. Runs on TurkerHub and displays results in the tab's title bar.\n"
+ "Dynamic Code Cache and Loader Test For anything that needs automatic updates, for people who are too dumb to check for themselves and for things that require more frequent updates than daily.\n"
+ "Code Loader Target Test Test for code loader\n"
+ "Moodle/Elearning/KMOOC test help Online Moodle/Elearning/KMOOC test help\n"
+ "MetaBot for YouTube (test) More information about users and videos on YouTube.\n"
+ "another test pls dont its a test for brofist.io\n"
+ "Test 1 Adds link to original size below each image\n"
+ "Felix Test try to take over the world!\n"
+ "HookAjax Test ww.soundsnap.com 铃声免费下载\n"
+ "Test try to take over the world!\n"
+ "小米搶折價卷 test try to take over the world!\n"
+ "test Sign in to External AFTLite Will log into External AFTlite automatcially\n"
+ "TCBG test description\n"
+ "Cross Site Test Cross Communication\n"
+ "Xhamster (TEST) - AUTO Delete Our Deleted Favs (videos/Users) v.3 - DEV - test AUTO Delete Our Deleted Favs (videos/Users) (author of the Library in use: Brock Adams)\n"
+ "HaxBall Test Mod See if mods work for you\n"
+ "Test Video warnings Warns to make test videos private\n"
+ "BrainMetrix - IQ Test Get the highest IQ on http://www.brainmetrix.com/free-iq-test/\n"
+ "New Reading Test Script Removed the useless verification code and easy to login.\n"
+ "test test script ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}