const regex = /^[A-Za-z0-9\x{0430}-\x{044F}\x{0410}-\x{042F}\._-]+@(?:[A-Za-z0-9\x{0430}-\x{044F}\x{0410}-\x{042F}]{1,2}|[A-Za-z0-9\x{0430}-\x{044F}\x{0410}-\x{042F}](?:(?<!(\.\.))[A-Za-z0-9\x{0430}-\x{044F}\x{0410}-\x{042F}.-])+[A-Za-z0-9\x{0430}-\x{044F}\x{0410}-\x{042F}])\.[A-Za-z\x{0430}-\x{044F}\x{0410}-\x{042F}]{2,}$/iu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}\\._-]+@(?:[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}]{1,2}|[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}](?:(?<!(\\.\\.))[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}.-])+[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}])\\.[A-Za-z\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}]{2,}$', 'iu')
const str = `potato@potato.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}