import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\d\\s]+|\\s\\d{1,2}[\\s\\,])*(\\d{3}[^\\d\\n]*\\d{3}[^\\d\\n]*\\d{4})*([^\\d\\s]+|\\s\\d{1,2}[\\s\\,])*";
final String string = "#input. Hello, there are 24 months in 2 years. also, there is a phone number here in this line, 555-555-5555\n"
+ "but did you know, the output now has 2, 4, and 2 as well as the number which we dont want?\n\n\n\n\n"
+ "555%555(5555\n"
+ "5555555855\n"
+ "555a555~5555\n"
+ "555 555 5555\n"
+ "555.555.5555\n\n\n";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}