package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\S\n]+`)
var str = `stuff aefouwehowr awrotgu jharoutgjeo oteuhstrhr
.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}