package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:a|b)pples)`)
var str = `fun&!! time`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}