import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?:/[*]{2}|[*]/).*$\\n?";
final String string = "/**\n"
+ "/// Lorem Ipsum is simply dummy text of the printing and typesetting industry. \n"
+ "/// Lorem Ipsum has been the industry's standard dummy text ever since the \n"
+ "/// 1500s, when an unknown printer took a galley of type and scrambled it to \n"
+ "/// make a type specimen book. It has survived not only five centuries, but \n"
+ "/// also the leap into electronic typesetting, remaining essentially \n"
+ "/// unchanged. It was popularised in the 1960s with the release of Letraset \n"
+ "/// sheets containing Lorem Ipsum passages, and more recently with desktop \n"
+ "/// publishing software like Aldus PageMaker including versions of Lorem Ipsum.\n"
+ " */\n\n"
+ "[rest of code]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}