$re = '/(?<=\w)-(?=\w)/';
$str = '03 - The-Basics-of-Querying-the-Dom.mov';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);