import re
regex = re.compile(r"<span class=\"historyDash\">-<\/span>\s*((?:[^\<]|\n)*?)\s*<\/div>", flags=re.MULTILINE)
test_str = ("\n"
"<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\" \"http://www.w3.org/TR/html4/loose.dtd\">\n"
"<html>\n"
"<head>\n"
"<title>Steam Community :: TripleThreat :: Persona name history</title>\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/shared/css/motiva_sans.css?v=F3z3QpekjE2f\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/shared/css/buttons.css?v=LNGz0aQrH--g\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/shared/css/shared_global.css?v=DOYfTk4evOTc\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/css/globalv2.css?v=RLlF4NbPEL4H\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/css/skin_1/global.css?v=gY3Z5G6712K3&client=0\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/css/skin_1/group_history.css?v=8TYZeQAleI4j\" rel=\"stylesheet\" type=\"text/css\" >\n"
"<link href=\"http://steamcommunity-a.akamaihd.net/public/css/skin_1/header.css?v=z3WBKGTLlnCN\" rel=\"stylesheet\" type=\"text/css\" >\n"
" <script>\n"
" (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){\n"
" (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),\n"
" m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)\n"
" })(window,document,'script','//www.google-analytics.com/analytics.js','ga');\n\n"
" ga('create', 'UA-33779068-1', 'auto', {\n"
" 'sampleRate': 0.4 });\n"
" ga('set', 'dimension1', false );\n"
" ga('set', 'dimension2', 'External' );\n"
" ga('set', 'dimension3', 'profiles' );\n"
" ga('set', 'dimension4', \"profiles\\/namehistory\" );\n"
" ga('send', 'pageview');\n\n"
" </script>\n"
" <script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/javascript/prototype-1.7.js?v=.55t44gwuwgvw\"></script>\n"
"<script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/javascript/scriptaculous/_combined.js?v=9XVsa_Ni33oN&l=english&load=effects,controls,slider,dragdrop\"></script>\n"
"<script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/javascript/global.js?v=VblJ8Wqm5w5i&l=english\"></script>\n"
"<script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/javascript/jquery-1.11.1.min.js?v=.isFTSRckeNhC\"></script>\n"
"<script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/shared/javascript/tooltip.js?v=._0UFXFGgvme-\"></script>\n"
"<script type=\"text/javascript\" src=\"http://steamcommunity-a.akamaihd.net/public/shared/javascript/shared_global.js?v=pU8RP8XZB6Hb&l=english\"></script>\n"
"<script type=\"text/javascript\">$J = jQuery.noConflict();\n"
"if ( typeof JSON != 'object' || !JSON.stringify || !JSON.parse ) { document.write( \"<scr\" + \"ipt type=\\\"text\\/javascript\\\" src=\\\"http:\\/\\/steamcommunity-a.akamaihd.net\\/public\\/javascript\\/json2.js?v=pmScf4470EZP&l=english\\\"><\\/script>\\n\" ); };\n"
"</script></head>\n"
"<body>\n"
"<center>\n"
"<!-- header bar, contains info browsing user if logged in -->\n"
"<div id=\"global_header\">\n"
" <div class=\"content\">\n\n"
" <div class=\"logo\">\n"
" <span id=\"logo_holder\">\n"
" <a href=\"http://store.steampowered.com/\">\n"
" <img src=\"http://steamcommunity-a.akamaihd.net/public/shared/images/header/globalheader_logo.png\" width=\"176\" height=\"44\">\n"
" </a>\n"
" </span>\n"
" <!--[if lt IE 7]>\n"
" <style type=\"text/css\">\n"
" #logo_holder img { filter:progid:DXImageTransform.Microsoft.Alpha(opacity=0); }\n"
" #logo_holder { display: inline-block; width: 176px; height: 44px; filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://steamcommunity-a.akamaihd.net/public/images/v5/globalheader_logo.png'); }\n"
" </style>\n"
" <![endif]-->\n"
" </div>\n\n"
" <div class=\"supernav_container\">\n"
" <a class=\"menuitem supernav\" href=\"http://store.steampowered.com/\" data-tooltip-type=\"selector\" data-tooltip-content=\".submenu_store\">\n"
" STORE </a>\n"
" <div class=\"submenu_store\" style=\"display: none;\" data-submenuid=\"store\">\n"
" <a class=\"submenuitem\" href=\"http://store.steampowered.com/\">Featured</a>\n"
" <a class=\"submenuitem\" href=\"http://store.steampowered.com/explore/\">Explore</a>\n"
" <a class=\"submenuitem\" href=\"http://store.steampowered.com/curators/\">Curators</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/my/wishlist/\">Wishlist</a>\n"
" <a class=\"submenuitem\" href=\"http://store.steampowered.com/news/\">News</a>\n"
" <a class=\"submenuitem\" href=\"http://store.steampowered.com/stats/\">Stats</a>\n"
" </div>\n\n\n"
" <a class=\"menuitem supernav\" style=\"display: block\" href=\"http://steamcommunity.com/\" data-tooltip-type=\"selector\" data-tooltip-content=\".submenu_community\">\n"
" COMMUNITY </a>\n"
" <div class=\"submenu_community\" style=\"display: none;\" data-submenuid=\"community\">\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/\">Home</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/discussions/\">Discussions</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/workshop/\">Workshop</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/greenlight/\">Greenlight</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/market/\">Market</a>\n"
" <a class=\"submenuitem\" href=\"http://steamcommunity.com/?subsection=broadcasts\">Broadcasts</a>\n"
" </div>\n\n"
" \n\n"
" \n"
" <a class=\"menuitem\" href=\"http://store.steampowered.com/about/\">\n"
" ABOUT </a>\n"
" \n"
" <a class=\"menuitem\" href=\"https://help.steampowered.com/en/\">\n"
" SUPPORT </a>\n"
" </div>\n"
" <script type=\"text/javascript\">\n"
" jQuery(function($) {\n"
" $('.tooltip').v_tooltip();\n"
" $('#global_header .supernav').v_tooltip({'location':'bottom', 'tooltipClass': 'supernav_content', 'offsetY':-4, 'offsetX': 1, 'horizontalSnap': 4, 'tooltipParent': '#global_header .supernav_container', 'correctForScreenSize': false});\n"
" });\n"
" </script>\n\n"
" <div id=\"global_actions\">\n"
" <div id=\"global_action_menu\">\n"
" <div class=\"header_installsteam_btn header_installsteam_btn_green\">\n"
" <div class=\"header_installsteam_btn_leftcap\"></div>\n"
" <div class=\"header_installsteam_btn_rightcap\"></div>\n"
" <a class=\"header_installsteam_btn_content\" href=\"http://store.steampowered.com/about/\">\n"
" Install Steam </a>\n"
" </div>\n\n"
" \n"
" <a class=\"global_action_link\" href=\"https://steamcommunity.com/login/home/?goto=id%2FTripleThreat%2Fnamehistory\">login</a>\n"
" | \n"
" <span class=\"pulldown global_action_link\" id=\"language_pulldown\" onclick=\"ShowMenu( this, 'language_dropdown', 'right' );\">language</span>\n"
" <div class=\"popup_block_new\" id=\"language_dropdown\" style=\"display: none;\">\n"
" <div class=\"popup_body popup_menu\">\n"
" <a class=\"popup_menu_item tight\" href=\"?l=bulgarian\" onclick=\"ChangeLanguage( 'bulgarian' ); return false;\">Български (Bulgarian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=czech\" onclick=\"ChangeLanguage( 'czech' ); return false;\">čeština (Czech)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=danish\" onclick=\"ChangeLanguage( 'danish' ); return false;\">Dansk (Danish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=dutch\" onclick=\"ChangeLanguage( 'dutch' ); return false;\">Nederlands (Dutch)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=finnish\" onclick=\"ChangeLanguage( 'finnish' ); return false;\">Suomi (Finnish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=french\" onclick=\"ChangeLanguage( 'french' ); return false;\">Français (French)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=german\" onclick=\"ChangeLanguage( 'german' ); return false;\">Deutsch (German)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=greek\" onclick=\"ChangeLanguage( 'greek' ); return false;\">Ελληνικά (Greek)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=hungarian\" onclick=\"ChangeLanguage( 'hungarian' ); return false;\">Magyar (Hungarian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=italian\" onclick=\"ChangeLanguage( 'italian' ); return false;\">Italiano (Italian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=japanese\" onclick=\"ChangeLanguage( 'japanese' ); return false;\">日本語 (Japanese)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=koreana\" onclick=\"ChangeLanguage( 'koreana' ); return false;\">한국어 (Korean)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=norwegian\" onclick=\"ChangeLanguage( 'norwegian' ); return false;\">Norsk (Norwegian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=polish\" onclick=\"ChangeLanguage( 'polish' ); return false;\">Polski (Polish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=portuguese\" onclick=\"ChangeLanguage( 'portuguese' ); return false;\">Português (Portuguese)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=brazilian\" onclick=\"ChangeLanguage( 'brazilian' ); return false;\">Português-Brasil (Portuguese-Brazil)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=romanian\" onclick=\"ChangeLanguage( 'romanian' ); return false;\">Română (Romanian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=russian\" onclick=\"ChangeLanguage( 'russian' ); return false;\">Русский (Russian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=schinese\" onclick=\"ChangeLanguage( 'schinese' ); return false;\">简体中文 (Simplified Chinese)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=spanish\" onclick=\"ChangeLanguage( 'spanish' ); return false;\">Español (Spanish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=swedish\" onclick=\"ChangeLanguage( 'swedish' ); return false;\">Svenska (Swedish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=tchinese\" onclick=\"ChangeLanguage( 'tchinese' ); return false;\">繁體中文 (Traditional Chinese)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=thai\" onclick=\"ChangeLanguage( 'thai' ); return false;\">ไทย (Thai)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=turkish\" onclick=\"ChangeLanguage( 'turkish' ); return false;\">Türkçe (Turkish)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"?l=ukrainian\" onclick=\"ChangeLanguage( 'ukrainian' ); return false;\">Українська (Ukrainian)</a>\n"
" <a class=\"popup_menu_item tight\" href=\"http://translation.steampowered.com\" target=\"_blank\">Help us translate Steam</a>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
"</div>\n"
"<div id=\"modalBG\" style=\"display: none\"></div><script type=\"text/javascript\">\n"
" g_sessionID = \"64b42b79f53030fe530e09fa\";\n"
" g_steamID = false;\n\n"
" // We always want to have the timezone cookie set for PHP to use\n"
" setTimezoneCookies();\n\n"
" $J( function() {\n\n"
" InitMiniprofileHovers();\n"
" InitEmoticonHovers();\n"
" window.BindCommunityTooltip = function( $Selector ) { $Selector.v_tooltip( {'tooltipClass': 'community_tooltip', 'dataName': 'communityTooltip' } ); };\n"
" BindCommunityTooltip( $J('[data-community-tooltip]') );\n"
" });\n\n"
" $J( function() { InitEconomyHovers( \"http:\\/\\/steamcommunity-a.akamaihd.net\\/public\\/css\\/skin_1\\/economy.css?v=k1KbRUnfe-Sy\", \"http:\\/\\/steamcommunity-a.akamaihd.net\\/public\\/javascript\\/economy_common.js?v=tsXdRVB0yEaR&l=english\", \"http:\\/\\/steamcommunity-a.akamaihd.net\\/public\\/javascript\\/economy.js?v=KgoJ8nBUSyBe&l=english\" );});</script><!-- /header bar -->\n"
"<div id=\"mainBody\">\n"
"<!-- main contents -->\n"
" <div id=\"mainContents\">\n"
" <!-- top content -->\n"
" <div id=\"topGroupAvatar\">\n"
" <div class=\"mediumHolder_default\"><div class=\"avatarMedium\"><a href=\"http://steamcommunity.com/id/TripleThreat\"><img src=\"http://cdn.akamai.steamstatic.com/steamcommunity/public/images/avatars/80/809c91ef963bce53195c205066f91babc729e647_medium.jpg\" /></a></div></div>\n"
" </div>\n"
" <h2>Persona name history</h2>\n"
" <h1><a id=\"topNameLink\" href=\"http://steamcommunity.com/id/TripleThreat\">TripleThreat</a></h1>\n"
" <!-- /top content -->\n"
" <!-- main body -->\n"
" <br />\n\n"
" <div class=\"historyItem\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 12:15pm</span>\n"
" <span class=\"historyDash\">-</span>\n"
" TripleThreat </div>\n"
" <div class=\"historyItemb\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 9:21am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" [FD] TripleThreat.blyat </div>\n"
" <div class=\"historyItem\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 8:45am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" 9 </div>\n"
" <div class=\"historyItemb\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 8:45am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" 7 </div>\n"
" <div class=\"historyItem\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 8:45am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" 5 </div>\n"
" <div class=\"historyItemb\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 8:45am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" 3 </div>\n"
" <div class=\"historyItem\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 23 @ 8:45am</span>\n"
" <span class=\"historyDash\">-</span>\n"
" 1 </div>\n"
" <div class=\"historyItemb\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 22 @ 6:10pm</span>\n"
" <span class=\"historyDash\">-</span>\n"
" This is a test </div>\n"
" <div class=\"historyItem\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jul 14 @ 5:28pm</span>\n"
" <span class=\"historyDash\">-</span>\n"
" [FD] TripleThreat </div>\n"
" <div class=\"historyItemb\">\n"
" <div class=\"historyIcon\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/HistoryNameChange.gif\" width=\"13\" height=\"12\" border=\"0\" /></div>\n"
" <span class=\"historyShort\">Name Changed</span>\n"
" <span class=\"historyDash\">-</span>\n"
" <span class=\"historyDate\">Jun 30 @ 5:44pm</span>\n"
" <span class=\"historyDash\">-</span>\n"
" admin </div>\n"
" <br clear=\"all\" />\n"
" </div>\n"
"<br clear=\"all\" />\n"
"</div>\n"
"<!-- footer -->\n"
" <div id=\"footer_spacer\"></div>\n"
" <div id=\"footer_responsive_optin_spacer\"></div>\n"
" <div id=\"footer\">\n"
" <div class=\"footer_content\">\n"
" <span id=\"footerLogo\"><img src=\"http://steamcommunity-a.akamaihd.net/public/images/skin_1/footerLogo_valve.png?v=1\" width=\"96\" height=\"26\" border=\"0\" alt=\"Valve Logo\" /></span>\n"
" <span id=\"footerText\">\n"
" © Valve Corporation. All rights reserved. All trademarks are property of their respective owners in the US and other countries.<br/>Some geospatial data on this website is provided by <a href=\"https://steamcommunity.com/linkfilter/?url=http://www.geonames.org\" target=\"_blank\" rel=\"noreferrer\">geonames.org</a>. <br>\n"
" <span class=\"valve_links\">\n"
" <a href=\"http://store.steampowered.com/privacy_agreement/\" target=\"_blank\">Privacy Policy</a>\n"
" | <a href=\"http://www.valvesoftware.com/legal.htm\" target=\"_blank\">Legal</a>\n"
" | <a href=\"http://store.steampowered.com/subscriber_agreement/\" target=\"_blank\">Steam Subscriber Agreement</a>\n"
" </span>\n"
" </span>\n"
" </div>\n"
" <div class=\"responsive_optin_link\">\n"
" <div class=\"btn_medium btnv6_grey_black\" onclick=\"Responsive_RequestMobileView()\">\n"
" <span>View mobile website</span>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")