$re = '/\$yourname\s*=\s*\"[^\"]+\";/';
$str = '$yourname="value";';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;