import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:%\\{LOGLEVEL:level\\}):\\s*%\\{DATA:message\\}\\s*(?:%\\{JAVACLASS:caller_class\\})\\s+\\[%\\{WORD:loglevel\\}\\]\\s+(\\[\\s*\\S+\\s+%\\{BASE10NUM:tstamp\\}.*?\\]\\s+)+(\\[\\s*\\S+\\s+%\\{BASE10NUM:memory\\}\\S*\\s+\\S+\\s+%\\{BASE10NUM:total\\}.*?\\])";
final String string = "INFO: 200000 packets. Current packet is class com.navtech.kernel.flat.FlatCombo [Loader] [tstamp: 1866 time: 1851.4 (30:51) split: 03.2] [Memory: 3.320G total: 22.20G free: 18.88G]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}