re = /(\s*[\{\[]?\%?[\s]*)[\@A-Za-z1-9_\.\s\+\-\*\\]*[^\s]([\s\*]*=[\s\*\$]*[\{\"]?)[\@A-Za-z1-9_\.\s\+\-\*\\]*(\s*[\}\"]?)([\}\]\%\s]*)/
str = '{% set type cookies : = "sugar cookies" %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end