re = /^(?!.*\.htm$)\/.*\/.*$/m
str = '/blabla/test
/blabla/
/blabla/blabla.ht
/blabla/blabla.html
/bla/blabla.htm
blabla/
/blabla
blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end