$re = '/^\+?[0-9()./-]{8,20}$/m';
$str = '0394448866 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);