$re = '/^(?=(?:[^\/]*\/){4,})(.*)/m';
$str = 'http://localhost:2000/machine/my-test-machine/3
http://localhost:2000/my-test-machine';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);