$re = '/\r/m';
$str = 'hello my guys
here\'s what we\'re looking for';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);