$re = '/^(?!\/api\/)(.+)\/$/m';
$str = '/api
/api/
/api/d
/api/d/
/api/dd
/api/dd/
/apidfdfsd/
/x
/x/
/xx
/xx/
/x/x
/x/x/
/x/xx
/x/xx/
/xx/x
/xx/x/
/xx/xx
/xx/xx/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);