#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((([0-9]*\.[0-9]+)|([0-9]+\.[0-9]*))(E(\+|-)?[0-9]+)?)|([0-9]+(?6)))$"
Local $sString = "12123123E12" & @CRLF & _
"" & @CRLF & _
"# Parts" & @CRLF & _
"(" & @CRLF & _
"" & @CRLF & _
"(" & @CRLF & _
"([0-9]*\.[0-9]+) |" & @CRLF & _
"([0-9]+\.[0-9]*)" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"(E(\+|-)?[0-9]+)?)" & @CRLF & _
"" & @CRLF & _
") |" & @CRLF & _
"" & @CRLF & _
"([0-9]+(?6)" & @CRLF & _
"" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")