$re = '/(?(?=^)[^=]*+=(?=.*=)|\G\s+)([^\s=]+)/';
$str = 'aaa =bbb ccc ddd eee= zzz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);