$re = '/([\\\\n]+)(?=[A-Z])/';
$str = '(2 months)\\n\\nML';
$subst = "__";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;