re = /\\.(*SKIP)(*FAIL)|[|]/
str = '|1 \\|2 \\\\|3 \\\\\\|4 \\\\\\\\|5 \\\\\\|\\\\|6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end