using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""|'(?!s\b|\s)|“)[^""'“â€]+(?:""|'(?!s\b)|â€)";
string input = @"""Lorem"" Ipsum is simply dummy text of the printing and typesetting industry. “Lorem Ipsum†has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book. It has survived not only “five centuries', but also the leap into electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets containing Lorem Ipsum passages, and more recently with 'desktop publishing"" software like ""Aldus' ""PageMaker"" including versions of Lorem Ipsum.
(Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of “type and scrambled†it to make a type ""specimen book""
(It has survived' not only ""five centuries"", but also the leap into electronic typesetting, remaining essentially unchanged.)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}