import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[)([^\\]]+)";
final String string = "Your Name (required)\n"
+ "[text* your-name]\n\n"
+ "Your Email (required)\n"
+ "[email* your-email]\n\n"
+ "Subject\n"
+ "[text your-subject]\n\n"
+ "Your Message\n"
+ "[textarea your-message]\n\n"
+ "[submit \"Send\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}