import re
regex = re.compile(r"^(\d|\[\d-\d\]| )+$", flags=re.MULTILINE)
test_str = ("0[1-3]123 45\n"
"[1-3]123 45\n"
"05[1-3]123 45\n"
"0[1-3]555 6789\n"
"0332 555 6789\n"
"0[1-11]123 45\n"
"[1-3]123a 34\n"
"[0-5]212123 45 67\n"
"[0-5]21223 45 67\n"
"[0-5]21223 45 67\n"
"1231232131 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")