#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imx)^" & @CRLF & _
"# get the title of this movie or series" & @CRLF & _
"(?P<title> " & @CRLF & _
" [-\w'\"]+" & @CRLF & _
" # match separator to later replace into correct title" & @CRLF & _
" (?P<separator> [ .] ) " & @CRLF & _
" # note this *must* be lazy for the engine to work ltr not rtl" & @CRLF & _
" (?: [-\w'\"]+\2 )*?" & @CRLF & _
")" & @CRLF & _
"# start of movie vs serie check" & @CRLF & _
"(?:" & @CRLF & _
" # if this is an episode, lets match the season " & @CRLF & _
" # number one way or another. if not, the year " & @CRLF & _
" # of the movie" & @CRLF & _
" (?:" & @CRLF & _
" # series. can be a lot prettier if we used perl regex..." & @CRLF & _
" # make sure this is not just a number in the title followed by our separator. " & @CRLF & _
" # like, iron man 3 2013 or my.fictional.24.series" & @CRLF & _
" (?! \d+ \2 )" & @CRLF & _
" # now try to match the season number" & @CRLF & _
" (?: s (?: eason \2? )? )?" & @CRLF & _
" (?P<season> \d\d? )" & @CRLF & _
" # needed to validate the last token is a dot, or whatever." & @CRLF & _
" (?: e\d\d? (?:-e?\d\d?)? | x\d\d? )? |" & @CRLF & _
" # this is likely a movie, match the year" & @CRLF & _
" (?P<year> [(\]]?\d{4}[)\]]? ) " & @CRLF & _
" )" & @CRLF & _
" # make sure this ends with the separator, otherwise we " & @CRLF & _
" # might be in the middle of something like "1080p"" & @CRLF & _
" (?=\2) |" & @CRLF & _
" # if we get here, this is likely still a movie." & @CRLF & _
" # match until one of the keywords" & @CRLF & _
" (?= BOXSET | XVID | DIVX | LIMITED | " & @CRLF & _
" UNRATED | PROPER | DTS | AC3 | AAC | BLU[ -]?RAY | " & @CRLF & _
" HD(?:TV|DVD) | (?:DVD|B[DR]|WEB)RIP | \d+p |Â [hx]\.?264" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "the.black.adder.3x01.dish.and.dishonesty.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"the.black.adder.3x02.ink.and.incapability.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"the.black.adder.3x03.nob.and.nobility.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"the.black.adder.3x04.sense.and.senility.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"the.black.adder.3x05.amy.and.amiability.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"the.black.adder.3x06.duel.and.duality.dvdrip.xvid-dvdiso.avi" & @CRLF & _
"Game.of.Thrones.S04E08.720p.HDTV.x264-KILLERS" & @CRLF & _
"Futurama.S06.720p.BluRay.X264-REWARD-SiNNERS" & @CRLF & _
"The.Grand.Budapest.Hotel.2014.1080p.BluRay.x264-BLOW" & @CRLF & _
"Another.Earth.2011.LIMITED.720p.BluRay.X264-AMIABLE" & @CRLF & _
"Game.of.Thrones.S04E09.720p.HDTV.x264-KILLERS" & @CRLF & _
"The.Green.Mile.1999.720p.BluRay.x264-HDCLASSiCS" & @CRLF & _
"Cosmos.A.Space.Time.Odyssey.S01E12.720p.HDTV.X264-DIMENSION" & @CRLF & _
"Game.of.Thrones.S04E10.720p.HDTV.x264-KILLERS" & @CRLF & _
"The Road 2009 Bluray DTS 720 p - TRiNiTY" & @CRLF & _
"Dead Poets Society (1989) 720p Blu-ray x264 DTS MSubs [DDR]" & @CRLF & _
"Garden.State.2004.720p.BluRay.X264-AMIABLE" & @CRLF & _
"The.Royal.Tenenbaums.2001.1080p.BluRay.X264-AMIABLE" & @CRLF & _
"Donnie.Darko.2001.1080p.PROPER.BluRay.x264-RRH" & @CRLF & _
"Hot.Fuzz.720p.HDDVD.x264-SEPTiC" & @CRLF & _
"True.Detective.S01E01.720p.HDTV.x264-KILLERS" & @CRLF & _
"Eternal Sunshine of the Spotless Mind 2004 DiVERSiTY" & @CRLF & _
"Non-Stop.2014.720p.BluRay.X264-AMIABLE" & @CRLF & _
"True.Detective.S01E02.720p.HDTV.x264-KILLERS" & @CRLF & _
"Fargo.S01E07.720p.HDTV.X264-DIMENSION" & @CRLF & _
"Silicon.Valley.S01E08.720p.HDTV.x264-KILLERS" & @CRLF & _
"True.Detective.S01E03.720p.HDTV.x264-KILLERS" & @CRLF & _
"Fargo.S01E08.720p.HDTV.X264-DIMENSION" & @CRLF & _
"Suits.S04E01.720p.HDTV.X264-DIMENSION" & @CRLF & _
"True.Detective.S01E04.720p.HDTV.x264-KILLERS" & @CRLF & _
"Fargo.S01E10.720p.HDTV.X264-DIMENSION" & @CRLF & _
"Suits.S04E02.720p.HDTV.X264-DIMENSION" & @CRLF & _
"True.Detective.S01E06.720p.HDTV.x264-2HD" & @CRLF & _
"The.Descendants.2011.720p.BluRay.x264-ALLiANCE" & @CRLF & _
"True.Detective.S01E07.720p.HDTV.x264-KILLERS" & @CRLF & _
"Killing Season 2013 DVDRip x264-NoRBiT" & @CRLF & _
"Game of Thrones S04E10 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E09 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E08 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E07 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E05 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E03 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E04 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E01 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E02 720p HDTV x264-2HD" & @CRLF & _
"Game of Thrones S04E06 720p HDTV x264-DIMENSION" & @CRLF & _
"Game of Thrones S04E10 HDTV x264-KILLERS" & @CRLF & _
"Watch Dogs-RELOADED" & @CRLF & _
"True Blood S07E01 720p HDTV x264-KILLERS" & @CRLF & _
"Non-Stop 2014 720p BluRay X264-AMIABLE" & @CRLF & _
"The Big Bang Theory S07E24 720p HDTV X264-DIMENSION" & @CRLF & _
"Game of Thrones S04E09 HDTV x264-KILLERS" & @CRLF & _
"24 S09E09 720p HDTV X264-DIMENSION" & @CRLF & _
"The Big Bang Theory S07E23 720p HDTV X264-DIMENSION" & @CRLF & _
"Game of Thrones S04E08 HDTV x264-KILLERS" & @CRLF & _
"Suits S04E02 720p HDTV X264-DIMENSION" & @CRLF & _
"Game of Thrones S04E06 INTERNAL 720p HDTV x264-BATV" & @CRLF & _
"The Big Bang Theory S07E22 720p HDTV X264-DIMENSION" & @CRLF & _
"Suits S04E01 720p HDTV X264-DIMENSION" & @CRLF & _
"Watch Dogs Hotfix-RELOADED" & @CRLF & _
"Wolfenstein The New Order-RELOADED" & @CRLF & _
"The Big Bang Theory S07E20 720p HDTV X264-DIMENSION" & @CRLF & _
"The Big Bang Theory S07E21 720p HDTV X264-DIMENSION" & @CRLF & _
"Suits S04E03 720p HDTV X264-DIMENSION" & @CRLF & _
"Californication S07E10 720p HDTV x264-DAA" & @CRLF & _
"True Blood S07E01 HDTV x264-KILLERS" & @CRLF & _
"24 S09E08 720p HDTV X264-DIMENSION" & @CRLF & _
"Game of Thrones S04E07 HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E05 HDTV x264-KILLERS" & @CRLF & _
"Silicon Valley S01E01 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E06 HDTV x264-KILLERS" & @CRLF & _
"24 S09E07 720p HDTV X264-DIMENSION" & @CRLF & _
"Californication S07E08 720p HDTV x264-DAA" & @CRLF & _
"The Big Bang Theory S07E19 720p HDTV X264-DIMENSION" & @CRLF & _
"24 S09E06 720p HDTV X264-DIMENSION" & @CRLF & _
"Californication S07E11 720p HDTV x264-KILLERS" & @CRLF & _
"The Wolf of Wall Street 2013 DVDScr x264-HaM" & @CRLF & _
"Game of Thrones S04E01 HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E10 1080p HDTV x264-BATV" & @CRLF & _
"The Wolf of Wall Street 2013 720p BluRay X264-AMIABLE" & @CRLF & _
"Game of Thrones S04E02 HDTV x264-2HD" & @CRLF & _
"Game of Thrones S04E03 HDTV x264-KILLERS" & @CRLF & _
"The Big Bang Theory S07E24 HDTV x264-LOL" & @CRLF & _
"24 S09E05 720p HDTV X264-DIMENSION" & @CRLF & _
"Southpark Stick Of Truth-RELOADED" & @CRLF & _
"300 Rise Of An Empire 2014 720p BluRay x264-BLOW" & @CRLF & _
"Californication S07E09 INTERNAL 720p HDTV x264-BATV" & @CRLF & _
"The Monuments Men 2014 720p BluRay x264-BLOW" & @CRLF & _
"The Big Bang Theory S07E18 720p HDTV X264-DIMENSION" & @CRLF & _
"Suits S04E01 HDTV x264-LOL" & @CRLF & _
"The Wolf Of Wall Street 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Her 2013 720p BluRay x264-SPARKS" & @CRLF & _
"The Big Bang Theory S07E17 720p HDTV X264-DIMENSION" & @CRLF & _
"The Big Bang Theory S07E23 HDTV x264-LOL" & @CRLF & _
"Family Guy S12E20 720p HDTV X264-DIMENSION" & @CRLF & _
"The Walking Dead S04E15 720p HDTV x264-2HD" & @CRLF & _
"300 Rise Of An Empire 2014 1080p BluRay x264-BLOW" & @CRLF & _
"24 S09E04 720p HDTV X264-DIMENSION" & @CRLF & _
"The Big Bang Theory S07E16 720p HDTV X264-DIMENSION" & @CRLF & _
"Californication S07E07 720p HDTV x264-DAA" & @CRLF & _
"Suits S04E02 HDTV x264-LOL" & @CRLF & _
"Snowpiercer 2013 BRRip XviD AC3-AQOS" & @CRLF & _
"Fargo S01E09 720p HDTV X264-DIMENSION" & @CRLF & _
"Fargo S01E10 720p HDTV X264-DIMENSION" & @CRLF & _
"Silicon Valley S01E08 720p HDTV x264-KILLERS" & @CRLF & _
"The Walking Dead S04E12 720p HDTV x264-REMARKABLE" & @CRLF & _
"Falling Skies S04E01 720p HDTV x264-KILLERS" & @CRLF & _
"The Big Bang Theory S07E22 HDTV x264-LOL" & @CRLF & _
"The Hobbit The Desolation of Smaug 2013 1080p BluRay x264-SPARKS" & @CRLF & _
"Thor The Dark World 2013 720p HDRip XviD-AQOS" & @CRLF & _
"Silicon Valley S01E02 720p HDTV x264-2HD" & @CRLF & _
"Californication S07E06 720p HDTV x264-DAA" & @CRLF & _
"True Detective S01E01 720p HDTV x264-KILLERS" & @CRLF & _
"The Walking Dead S04E13 720p HDTV x264-2HD" & @CRLF & _
"Robocop 2014 720p BluRay x264-SPARKS" & @CRLF & _
"The Walking Dead S04E16 PROPER 720p HDTV x264-KILLERS" & @CRLF & _
"The Big Bang Theory S07E21 HDTV x264-LOL" & @CRLF & _
"The Grand Budapest Hotel 2014 720p BluRay x264-BLOW" & @CRLF & _
"24 S09E03 720p HDTV X264-DIMENSION" & @CRLF & _
"True Detective S01E03 720p HDTV x264-KILLERS" & @CRLF & _
"Game of Thrones S04E04 REPACK HDTV x264-KILLERS" & @CRLF & _
"24 S09E01 720p HDTV X264-DIMENSION" & @CRLF & _
"24 S09E02 720p HDTV X264-DIMENSION" & @CRLF & _
"Silicon Valley S01E03 720p HDTV x264-KILLERS" & @CRLF & _
"The Big Bang Theory S07E15 720p HDTV X264-DIMENSION" & @CRLF & _
"Dallas Buyers Club 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Walking Dead S04E11 720p HDTV x264-2HD" & @CRLF & _
"How I Met Your Mother S09E23-E24 720p HDTV x264-REMARKABLE" & @CRLF & _
"Suits S03E16 720p HDTV x264-KILLERS" & @CRLF & _
"GRID Autosport-RELOADED" & @CRLF & _
"Silicon Valley S01E05 720p HDTV x264-KILLERS" & @CRLF & _
"Vikings S02E10 720p HDTV x264-2HD" & @CRLF & _
"Silicon Valley S01E06 720p HDTV x264-2HD" & @CRLF & _
"300 Rise Of An Empire 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Californication S07E05 720p HDTV x264-2HD" & @CRLF & _
"Silicon Valley S01E04 720p HDTV x264-KILLERS" & @CRLF & _
"The Wolf Of Wall Street 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Snowpiercer 2013 BRRip XviD AC3-AQOS" & @CRLF & _
"Dallas Buyers Club 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"300 Rise Of An Empire 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"American Hustle 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Grand Budapest Hotel 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"This Is The End 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Non-Stop 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"A Million Ways To Die In The West 2014 720p New Webrip x264 AC3 TiTAN" & @CRLF & _
"Captain Phillips 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Lego Movie 2014 720p HDRip XviD-AQOS" & @CRLF & _
"Now You See Me 2013 EXTENDED 720p BDRip x264 AAC-ViSiON" & @CRLF & _
"Bad Neighbours 2014 720p WEBRIP x264 AC3-EVE" & @CRLF & _
"Gravity 2013 720p WEBRiP XViD AC3-LEGi0N" & @CRLF & _
"The Raid 2 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Under The Skin 2013 720p HDRIP x264 AC3 TiTAN" & @CRLF & _
"The Hobbit The Desolation Of Smaug 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Wolverine 2013 EXTENDED 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Pompeii 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"12 Years A Slave 2013 720p BDRip XviD AC3-ViSiON" & @CRLF & _
"Frozen 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Man Of Steel 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Elysium 2013 720p WEBRiP XViD AC3-LEGi0N" & @CRLF & _
"The Monuments Men 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Snowpiercer 2013 720p BDRip x264 AAC-ViSiON" & @CRLF & _
"The Hunger Games Catching Fire 2013 IMAX EDITION 720p BRRip XviD AC3-ViSiON" & @CRLF & _
"Robocop 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Jack Ryan Shadow Recruit 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Bad Words 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Double 2014 720p HDRip x264 AAC-FooKaS" & @CRLF & _
"Prisoners 2013 720p WEB-DL x264 AAC-ViSiON" & @CRLF & _
"The Secret Life Of Walter Mitty 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Riddick 2013 UNRATED DC 720p WEB-DL XviD AC3-ELiTE" & @CRLF & _
"47 Ronin 2013 720p WEB-DL XviD AC3-ELiTE" & @CRLF & _
"Enders Game 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Oblivion 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"That Awkward Moment 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Raid 2 2014 BDRip x264-GECKOS" & @CRLF & _
"47 Ronin 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Grand Budapest Hotel 2014 720p WEBRIP x264 AC3-EVE" & @CRLF & _
"Her 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Don Jon 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"3 Days to Kill 2014 EXTENDED 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Lego Movie PROPER 720p HDRIP x264 AC3 TiTAN" & @CRLF & _
"Thor The Dark World 2013 720p WEBRiP XViD AC3-LEGi0N" & @CRLF & _
"White House Down 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Hunger Games Catching Fire 2013 IMAX EDITION 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Lego Movie 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Bad Grandpa 2013 UNRATED 720p WEB-DL XviD AC3-ELiTE" & @CRLF & _
"Non-Stop 2014 BRRip XviD AC3-SANTi" & @CRLF & _
"Escape Plan 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Despicable Me 2 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Delivery Man 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Blended 2014 720p WEBRIP x264 AC3-EVE" & @CRLF & _
"RoboCop 2014 720p WEBRIP x264 AC3-EVE" & @CRLF & _
"The Great Gatsby 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Fast And Furious 6 2013 720p WEBRiP XViD AC3-LEGi0N" & @CRLF & _
"A Million Ways to Die in the West 2014 HC 720p WEBRIP x264 AC3-MiLLENiUM" & @CRLF & _
"Red 2 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Lone Ranger 2013 720p BDRip x264 AAC-ViSiON" & @CRLF & _
"World War Z 2013 UNRATED 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Enemy 2013 LIMITED 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Vampire Academy 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Legend Of Hercules 2014 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Non-Stop 2014 BDRip X264-AMIABLE" & @CRLF & _
"Afflicted 2013 LIMITED 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Street Fighter Assassin's Fist 2014 720p HDRip x264 AC3 TiTAN" & @CRLF & _
"Veronica Mars 2014 HDRip AC3 XviD-EVO" & @CRLF & _
"2 Guns 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Anchorman 2 The Legend Continues 2013 UNRATED 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Lone Survivor 2013 720p WEBRiP XVID AC3-MAJESTIC" & @CRLF & _
"Kick-Ass 2 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Jack Ryan Shadow Recruit 2014 HDRip XviD AC3-EVO" & @CRLF & _
"Rush 2013 720p BRRip x264 AAC-ViSiON (Happy New Year from ViSiON!)" & @CRLF & _
"Calvary 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Hunger Games Catching Fire 2013 BRRip XviD AC3-SANTi" & @CRLF & _
"Jack Ryan Shadow Recruit 2014 720p WEBRIP x264 AC3-EVE" & @CRLF & _
"Thor The Dark World 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Bad Neighbours 2014 WEBRip NEW SOURCE Xvid Mp3 MiLLENiUM" & @CRLF & _
"Prisoners 2013 720p BRRiP x264 AC3-LEGi0N" & @CRLF & _
"Elysium 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Pacific Rim 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Saving Mr Banks 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"The Monuments Men 2014 BDRip x264-COCAIN" & @CRLF & _
"Joe 2013 1080p WEBRIP x264 AC3-EVE" & @CRLF & _
"I Frankenstein 2014 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"The Secret Life Of Walter Mitty 2013 720p WEB-DL XviD AC3-ELiTE" & @CRLF & _
"The Monuments Men 2014 BRRip XviD AC3-AQOS" & @CRLF & _
"About Time 2013 720p BDRip XviD AC3-ELiTE" & @CRLF & _
"Frozen 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Enemy 2013 720p WEBRiP XViD AC3-LEGi0N" & @CRLF & _
"I Frankenstein 2014 BRRip XviD AC3-SANTi" & @CRLF & _
"Out Of The Furnace 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"Walk of Shame 2014 LIMITED 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Iron Man 3 2013 720p BDRip x264 AAC-ViSiON" & @CRLF & _
"The Monuments Men 2014 720p BDRIP x264 AC3-EVE" & @CRLF & _
"Anchorman 2 The Legend Continues 2013 720p HDRIP x264 AC3 TiTAN" & @CRLF & _
"Captain Phillips 2013 720p BRRiP XViD AC3-LEGi0N" & @CRLF & _
"Jack Ryan Shadow Recruit 2014 BRRip XviD AC3-SANTi" & @CRLF & _
"Cloudy With A Chance Of Meatballs 2 2013 720p BRRip x264 AAC-ViSiON" & @CRLF & _
"my.fictional.24.series.s01e02.720p-firas "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")