package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`aa`)
var str = `aa aa aa
aa aa aa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}