import Foundation
let pattern = #"\s*\S*(?:vssx|vddx)\S*\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
garble variable10 variable1 vssx vddx xi_21_vssx vddx_garble_21 xi_blahvssx_grbl_2
garble vssx vddx variable1 xi_21_vssx variable10 vddx_garble_21 xi_blahvssx_grbl_2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)