# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"<div[^>]*id=\"THIS\"[^>]*>(.*?)(</div>).+?\n")
test_str = ("<div class=\"viewport viewport_h\" style = \"overflow: hidden;\" >\n"
" <div id=\"THIS\" class=\"overview overview_h\">\n"
" <ul>\n"
" <li>some txt to be captured</li>\n"
" <li>some txt to be captured</li>\n"
" <li>some txt to be captured</li>\n"
" </ul>\n"
" <div>\n"
" \" some text to be captured\"\n"
" </div>\n"
" </div>\n"
"</div>\n"
"\"some text not to be captured\"\n"
"</div>\n"
"<div class=\"scrollbar_h\">\n"
"<div class=\"track_h\"></div>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.