import re
regex = re.compile(r"^((401178|401179|431274|438935|451416|457393|457631|457632|504175|627780|636297|636369|(506699|5067[0-6]\d|50677[0-8])|(50900\d|5090[1-9]\d|509[1-9]\d{2})|65003[1-3]|(65003[5-9]|65004\d|65005[0-1])|(65040[5-9]|6504[1-3]\d)|(65048[5-9]|65049\d|6505[0-2]\d|65053[0-8])|(65054[1-9]|6505[5-8]\d|65059[0-8])|(65070\d|65071[0-8])|65072[0-7]|(65090[1-9]|65091\d|650920)|(65165[2-9]|6516[6-7]\d)|(65500\d|65501\d)|(65502[1-9]|6550[3-4]\d|65505[0-8]))[0-9]{10,12})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("5090402132456747\n"
"6500311231321321\n"
"6500321231321321\n"
"6500331231321321\n"
"6500341231321321\n"
"6500351231321321\n"
"6500391231321321\n"
"6500401231321321\n"
"6500451231564654\n"
"6500511231564654\n"
"6504051231321331\n"
"6504851231321321\n"
"6505411231321313\n"
"6507001321321313\n"
"6507201231321133\n"
"6509011235646432\n"
"5066998786245463\n"
"6516527887324132\n"
"6550007896242321\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")