#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})"
Local $sString = "### ACL de tiempo. " & @CRLF & _
"## ¿Son estos los horarios que necesita? " & @CRLF & _
"time laboral { " & @CRLF & _
" weekly mtwhf 07:15 - 12:29 " & @CRLF & _
" weekly mtwhf 13:15 - 16:00 " & @CRLF & _
"} " & @CRLF & _
" " & @CRLF & _
"time almuerzo{ " & @CRLF & _
" weekly mtwhf 12:30 - 13:14 " & @CRLF & _
"} " & @CRLF & _
" " & @CRLF & _
"time noche { " & @CRLF & _
" weekly mtwhf 15:45 - 23:55 " & @CRLF & _
" weekly mtwhf 00:01 - 07:14 " & @CRLF & _
"} " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")