re = /^(?:\[[^\]]*\]|\([^()]*\))\s*|\s*(?:\[[^\]]*\]|\([^()]*\))/m
str = '[xxx] hey [xx] (xhini) rexhin (zzz)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result