$re = '/^70000@*$/';
$str = '970000@ILoveFishSticksAndTarTarSauce.com:5060';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);