$re = '/^(?:,\d+)+,$/m';
$str = ',453,399,2093,11,309,
,453,
323,453,
,343,323';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);