using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*\s*(.*?)<(.*?)>";
string input = @"--> Welcome to Stack Overflow<http://stackoverflow.com>
Take the tour<http://stackoverflow.com/tour> |Need help?<http://stackoverflow.com/help> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}