$re = '/^.+(?=\.\d+$)/m';
$str = '10.10.10.10
192.168.32.43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);