$re = '/[A-Z]*(?=\s)|(?<=\s)[A-Z]*
/';
$str = 'THE NEED OF FOLLOWING A RELIGION ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);