$re = '/(?<==)\d+(?=,)/mi';
$str = 'numberone=1,numbertwo=2,numberthree=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);