$re = '/onclick[^(]*\(\'([^\']+)/im';
$str = '<li><a href="#blog" data-rel="close" onclick="getRSSFeed(\'http://moi.ir/Portal/RssPage/ShowRss.aspx?CategoryID=541ac873-3706-4f31-97e7-5cd6d51170eb\',\'BlogList\');">news</a></li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);