import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ "(?<s> 0(?&b)1 | 1(?&b)0 | 1(?&c)1 | 0(?&c)0 )\n"
+ "(?<a> 0 | 1 )\n"
+ "(?<b> (?&a)(?&b)(?&a) | (?&d)1 )\n"
+ "(?<c> (?&a)(?&c)(?&a) | (?&d)0 )\n"
+ "(?<d> _(?&e) | _ )\n"
+ "(?<e> (?&a)(?&e) | (?&a) )\n"
+ ")\n"
+ "^(?&s)$";
final String string = "0_00\n"
+ "01_101";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}