re = /\\"|"(?:\\"|[^"])*"|(\+)/
str = '\\"sd\\" "inside", "", outside, "inside" "insi\\"de"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end