re = /^(?!.*([A-Za-z0-9])\1{3})[A-Za-z0-9._%+-]{3,}\@[A-Za-z0-9-]{3,}\.[A-Za-z]{2,4}$/m
str = 'test@test.ccccom
test@test.coooom
test@test.com
test@test.cccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end