import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9._%+-]{3,}\\@[A-Za-z0-9.-]{3,}\\.(?:(?!(.)\\1{3})[a-zA-Z]){2,4}$";
final String string = "test@test.cccc\n"
+ "test@test.ccc\n"
+ "test@test.coooom\n"
+ "test@test.com\n"
+ "test@test.cccc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}