re = /(?<!\S)Jack(?:#[^\s,]*)?/m
str = 'A Jack# Jack#aNyWord Jack, Jack testJack'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end