re = /^(?:\/\/[^\r\n]*)|\(\*[\s\S]*?(?:\*\)|$)|^\{(?!\$)[\s\S]*?(?:\}|$)/m
str = '{text in here}
This is a compiler directive (not a comment):
{$text in here}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end