import re
regex = re.compile(r"^(\S+) (\S+) (\S+) \[([\w:/]+\s[+\-]\d{4})\] \"(\S+) (\S+)\s*(\S+)?\s*\" (\d{3}) (\S+)", flags=re.MULTILINE)
test_str = ("127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET /images/launch-logo.gif HTTP/1.0\" 200 1839\n"
"127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET /\" 200 1839\n\n"
"127.0.0.1 - - [01/Jul/1995:00:00:01 -0400] \"GET / \" 200 1839")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")